
After the thrill of being able to use the power of 
Photoshop in so many different ways wears off the 

fatigue of having to do so many of the same tasks over 
and over sets in. Routine tasks become… well, routine. 
And you’d really prefer to spend most of your time on 
the fun, creative things you can do with images. Now 
you’re ready to take advantage of Photoshop’s automa-
tion tools to accomplish common tasks – even complex 
ones – with a single click.

But there’s more to automation than alleviating bore-
dome, there’s money involved. The old adage “time is 
money” is never more true than when you’re charging 
by the hour. If you can accomplish tasks twice as fast as 
your competitor you can make twice as much money in 
the same time – or make the same amount of money in 
half the time and take the rest of the day off!

With automation you can do faster work, make fewer 
mistakes, make more money and minimize your frustra-
tion level – not to mention your blood pressure. The 
cliché about working smarter rather than harder is actu-
ally true here.

•	Actions

•	Batch Processing

•	Droplets

Automation
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Actions
“Action” is Adobe’s word for what most other software mak-
ers call a “Macro”. It’s a procedure you record while perform-
ing it once and which you can then recall with a mouse click 
or keyboard shortcut any time in the future. To do this on 
Photoshop you’ll need to open the Actions Panel through the 
main menu (Window > Actions) or via a keyboard shortcut 
(Alt+F9/Option+F9).

The Actions Panel shown here 
looks something like the Layers 
Panel, but the folders expand 
into individual Actions. There are 
about a dozen Actions that are 
included with Photoshop in the 
Default Actions folder. Click the 
triangle next to the folder icon to 
see them. But the real power of 
Actions comes from creating your 
own, so let’s begin doing just that.

Download and open the file at 
www.robertstech.com/fotoshop/italy17.php

If you expanded the Default Actions folder earlier, click on 
the triangle again to compact it.

Click the New Folder icon at the 
bottom of the Actions Panel. In 
the dialog box that pops up enter 
your name or something that tells 
you this is your own, personal set 
of Actions. Now you’re ready to 
record an Action of your own.

Recording an Action

To start recording an Action, click the New Action icon at the 
bottom of the Actions Panel. 

You’ll get a dialog 
which asks you to 
name the Action – 
you can also choose 
which Set (folder) 
it goes into, create a keyboard shortcut and assign it a color 
code. Enter “Web size with drop shadow” into the Name box 
and then click the Record button. From this point on every-
thing you do (with some limitations to be discussed later) will 
be “recorded” to be exectuted whenever you run this Action 
in the future. Notice that the “Record” button is now lit up.

Let’s begin by resizing the image. From the main menu 
choose Image > Image Size and reduce the image dimen-
sions to 600 x 400 pixels.

Now click the Stop icon at the bottom of the Actions Panel. 
At this point, nothing you do will be recorded as part of the 
Action. Now click the Record icon to resume recording…

Use the keyboard shortcut Ctrl+J (Win) or Cmd+J (Mac) to 
duplicate the background Layer (it will be called Layer 1).

Press the “D” key to set foreground and background colors 
to default. Choose Image > Canvas Size, check the “Relative” 
box and add 50px to both width and height.

Apply a Drop Shadow Layer Style to Layer 1. Set the Angle to 
135°, Distance to 7px and Size to 4px with Anti-Aliasing on.

Flatten the image and Save As in a different location at 
JPEG quality setting 5, progressive. Close the file (Ctrl+W or 
Cmd+W) and then click the Stop icon in the Actions Panel.

Expand/Compact

New ActionStop

Record

Play (Run Selected Action)

New Folder (Set) 
of Actions



At this point you have recorded a 
complete action and your Actions 
Panel should look like this:

Any step that involves a dialog 
box will have a little triangle next 
to it. Click the triangle to the left 
of “Image Size”, “Canvas Size”, 
Set Layer Styles…” or “Save” 
and it will expand to show all the 
details of what was done in that 
step. (You can also collapse/expand the entire Action by click-
ing the triangle next to “Web size with drop shadow”.)

Now download and open the file at 
www.robertstech.com/fotoshop/stinson-beach.php

Target your new “Web size with drop shadow” Action (so it’s 
highlighted in the Actions Panel) and click the Play icon. All 
the steps in your Action will be executed on the new image.

Many long, complex tasks that you need to perform regularly 
can be turned into Actions that you can perform with a single 
click for a potentially huge savings in time and effort.

Editing Actions

Any step in an Action that involves a dialog box can be edited 
after it’s recorded. As we’ve seen, these are indicated by a 
white triangle to their left.

You have to have an image open to edit an Action, but any 
image will do. Double-click on the step in the Action you 
want to change and the appropriate dialog will open. Set the 
parameters you want, click OK and the new values will be 
saved. At this point the step you specified will be performed on 
the open image – just use Undo to change it back and close 
the image without saving.

You can also make a particular dialog open every time you 
run an Action, to customize it each time you use it. This can 
be useful for Actions involving pixel values that have to be 
changed for images of different sized (see “Real World Prob-
lems” above). Near the left edge of the Actions Panel, next 
to the check mark column, is a column of grayed-out boxes. 
Click the box next to the step 
you want to adjust. Now that 
dialog will appear with each running of the Action.

Skipping Steps in Actions

What about those check marks at the left edge of the Actions 
Panel? Click any one of those off and that step will be skipped 
when you run the Action. (This might cause trouble if later 
steps are dependent on changes made by the deactivated 
step, so do this with care.) You can create duplicate steps 
with variations on the same process and deactivate all but 
one any time you use this Action.

REAL WORLD PROBLEMS
Actions and Pixel Dimensions

A potential speed bump when using Actions is that some of them 
won’t work equally well on images of all sizes. A drop shadow 
with the Distance setting at 5 pixels may work perfectly for a 300 
x 400 web image but it will be virtually invisible on 4000 x 6000 
image being used for print.

Any change that involves settings that are in pixels (rather than 
percentage or an arbitrary scale – 1-10, for example) will look 
different in proportion to image size. It is likely to be exaggerated 
or insignificant with images much larger or smaller than the one 
with which the Action was recorded.

Someday Photoshop may have the option of using a percentage 
(of image diagonal or long edge) instead of a number of pixels 
in Filters and Layer Styles, etc. but as things stand now you just 
have to be careful in using these kinds of processes in Actions.



Limitations

Actions have definite limitations and you need to be aware 
of them before moving on to more advanced automation. 
You can’t, for example, record the changes in image view 
(on-screen magnification) or any printing settings. Normally 
you can’t record Tool use (like using the Paint Brush or Heal-
ing Brush) – but you can do this if you switch on “Allow Tool 
Recording” in the Action Panel’s Panel Menu. This is made 
optional because manual Tool use is so image-specific it’s 
unlikely you’ll ever need exactly the same brush strokes, etc. 
on more than one image.

Saving Your Actions

After working with Photoshop for long enough you’ll prob-
ably create your own set or sets of Actions. Though you can’t 
save individual Actions you can save sets (folders) of Actions. 
Target your folder/set in the Actions Panel, go the Panel 
Menu and choose “Save Actions…”. Your set of Actions will 
be saved with an “.atn” file extension. By copying this file to 
other computers you can have all your own custom Actions 
available anywhere. You can even get Actions from other 
people and find downloadable sets of Actions on the web. 

Batch Processing
It goes without saying that Actions can save you a lot of time. 
Imagine having to perform the “Web size with drop shadow” 
Action we just created – or a much more complex process – 
on a dozen images manually, as opposed to a one-click step. 
But what if you had, rather than a dozen images, a hundred? 
How about four hundred? That would have you longing for a 
way to do all of them in an automated fashion, wouldn’t it? 
That’s exactly what Batch Processing does.

Batch Processing work best if you plan ahead and organize 
where the images will be coming from and going to before 

you begin. Usually it’s best to place all images to be pro-
cessed in one directory (folder) on your hard drive. And make 
result of your Action or Batch go to another.

Try Running a Batch Process

Create a new directory (folder) on your hard drive and name 
it “Before”. Place the two original images you downloaded 
for this chapter into it. 

Create another new folder beside the first; name it “After”.

From the main menu choose File > Automate > Batch to 
open the Batch Processing dialog box shown at right.

At the top of the dialog is a section labeled Play. This is where 
you choose the Action set and the specific Action you want 
to carry out. Choose the “Web size with drop shadow” Action 
you just created (“Recording an Action”, page 238).

Next down is the Source section. The drop-down list lets you 
choose what kind of source you’re going to use, “Folder” and 
“Opened Files” being the most common. Opened Files will 
apply your chosen Action to any image files you currently 
have open in Photoshop, but no others. Folder will let you 
carry out your Action on all files within a specific folder on 
your hard drive. In our example we’ll use “Folder”; click the 
“Choose” button below it and in the dialog that opens next 
locate the “Before” folder where you put your images.

Now let’s look at the options in the Source section:

Override Action “Open” Commands 
The Batch Process itself will open all the files in the folder 
you’ve specified, so if the Action you’ve chosen includes a 
“File Open” command it’s unnecessary and you can override 
it. The Action we created has no “File Open” command in it, 
so leave this box unchecked.



Include All Subfolders 
If you have folders within folders in your Source directory, 
checking this box will include all the files within them. That 
doesn’t apply in our case so leave this box unchecked.

Suppress File Open Options Dialogs 
This prevents dialog boxes that appear with options during 
the opening of image files – usually digital camera Raw files. 
Not applicable to our JPEGs so leave this box unchecked.

Suppress Color Profile Warnings 
This makes Photoshop ignore any warnings about mis-
matched or missing ICC Profiles in the images being pro-
cessed. Check this box only if you realy don’t want the Batch 
Process to be interrupted and if you’re sure Color Manage-
ment issues either aren’t present or don’t matter. We’ll leave 
this box unchecked.

Now we’ll set up the Destination section.

First, you have to decide where to place each file after the 
Action is performed on it. The Destination drop-down list 
gives you three choices: None, Save and Close and Folder. 
None will leave the file open in Photoshop and unsaved, 
unless your Action contains Save and Close steps. Save and 
Close simply saves the file in its current location and closes 
it after the Action (modifying your existing file rather than 
making a modified copy). The Folder option lets you specify a 
new location where a modified copy of your file will go – this 
lets you keep the original image in its original form.

Since you created a new Folder called “After” specifically for 
this Batch, you should choose Folder from the drop-down list.

Next, click the “Choose” button, navigate to the “After” 
folder you created and click OK. The Batch will now save 
all your completed files there (while it leaves the unaltered 
originals in the “Before” folder).

Now you’ll recall we included a “Save As JPEG” step as part 
of our Action, but it saved the image in a different folder (we 
hadn’t created the “New” folder yet). So we need to override 
that step. Check the Override Action “Save As” Commands 
box. This will make the Batch Process ignore the Save As 
command in the save in the “After” folder you have specified.

Batch Process Dialog Box



There is a section below the override box where you can re-
name your files as the Batch Process runs. This can be useful 
if you want to assign specific file names to associate all the 
images for one job or one client with each other. You can get 
quite sophisticated with your file naming if you like, but it can 
get pretty complex if you do. If you want to re-name your im-
ages I suggest you stick with the default options in the drop-
down lists. Play with the available options as much as you like 
but remember to make “extension” the last one!

The “Compatibility” check boxes are there so you can decide 
if you want to insure that your new file names are compatible 
with Mac, Windows or Unix operating systems. It defaults 
to the operating system of the computer you’re currently 
running Photoshop in; checking other boxes makes the file 
names compatible with other operating systems as well (Unix 
is used on many many web servers so may be helpful for web 
images). These options are especially useful if your file names 
include punctuation marks or special characters.

The Errors section is for advanced users. If something goes 
wrong in your batch you usually want it to stop; that’s the 
default and I suggest you keep it. You can make the Batch 
continue (or try to continue) through any errors and leave a 
text file listing the errors when it’s finished. In general you 
should leave it at its default setting of “Stop for Errors”.

Now, with all these settings as shown in the illustration, 
click OK and the Batch Process will run. With most comput-
ers these days it should only take a few seconds to process 
both images. You’ll end up with two new small web images 
with drop shadows in the “After” folder and the two orignial 
images, unaltered, in the “Before” folder. You could easily run 
this Batch Process on a Folder containing hundreds of images 
with the same amount of effort. With more complex actions 
the time savings are even greater (in fact, you can create one 
Action that performs several other Actions and Batch Process 
that – the possibilities are endless).

Droplets
Droplets are little executable files that perform Actions. You 
can save them anywhere on your computer and use them by 
dragging and dropping image files onto them. The Droplet 
opens Photoshop and performs the Action programmed into 
it. If there’s a particular Batch Process you do frequently it 
may be worth turning it onto a Droplet.

Choose File > Automate > Create Droplet… from the main 
menu to get the dialog box shown here. It’s very similar to 
the Batch Process dialog except that it has no Source section 
– because a Droplet only works on files you drag and drop 
onto it – and it has a Save Droplet In section at the top for you 
choose where you’re going to save the Droplet file.

Where you save your Droplet is up to you. Click the Choose 
button at the top and pick a location (I’ve chosen the Desktop 
for this example) and a name for your Droplet. Use a name 
that’s descriptive of the Action the Droplet performs (you can 
even use the same name you gave the Action). 



In the Play section choose the same “Web size with drop 
shadow” Action we used in the Batch example. 

Everything else works just like the Batch Process dialog.

When you click OK the Droplet file is created in the location 
you specified. Here’s what the icon on my desktop looks like:

To use the Droplet just drag any image file onto the icon. 

Automation Tips

•	 Any procedures that you find yourself performing over 
and over are candidates for Actions and/or Batches.

•	 Group your Actions in folders (sets) with similar kinds 
of usage (web Actions, for example).

•	 Avoid making Actions unnecessarily complex; several 
short Actions can be run individually or made to run 
sequentially within another Action.

•	 Be aware of Color Profile mismatches and other 
glitches that may pop up in long Batch Processes; 
there’s nothing more frustrating than going to lunch 
while a Batch of 500 images runs and coming back to 
find it stopped on the third one because it was waiting 
for you to click OK in a dialog box you didn’t expect!

•	 Test your Batch Process with two or three files before 
running it on a really big batch (see above). 



Online content for this chapter at http://www.robertstech.com/fotoshop/chapter30.php

Automation

•	 Automation allows you to simplify and speed up 
repetitive tasks, saving you time and increasing 
productivity.

•	 ACTIONS – let you save complex processes and apply 
them to an image in one step.

•	 BATCH PROCESSES – Let you apply Actions to many 
images in one step.

•	 DROPLETS – Let you save commonly-used Batch 
Processes and use them by drag-and-drop.

Actions

•	 An Action is what other software applications call a 
“macro” – a saved script that records complex, multi-
step tasks and allows you to perform them with a 
single click.

•	 Actons are recorded, organized and run through the 
Actions Panel.

•	 You can temporarily disable specific steps in an Action 
if necessary.

•	 Any steps in an Action that involve setting values in 
a dialog box can be edited after the Action has been 
recorded.

•	 You can include saving and closing a file in an Action.

•	 Some Photoshop tasks, like printing or changing view 
magnification, cannot be recorded in an Action.

•	 You can save sets (folders) of Actions as .atn files 
which can then be copied to other computers; there 
are downloadable .atn Action sets available on the 
web.

Batch Processes

•	 A Batch can be run on a directory (Folder) of images 
or on image files that are currently open in Photoshop.

•	 A Batch Process can either leave images open after 
the Action is performed or save the images to s 
designated location.

•	 Image Open and Save steps in an Action can be 
overridden in a Batch Process if you necessary.

Droplets

•	 Droplets are executable files that perform specific 
Actions.

•	 Creating a Droplet is very similar to creating a Batch 
Process

•	 When complete, a Droplet is an executable file that 
you save on your computer; to use it, you drag and 
drop image files onto it.

Keyboard Shortcuts from this Chapter:

Open the Actions Panel: 
Alt + F9 (Win) or Option+ F9 (Mac)
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